Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2023 - 10:00 EST
Scheduled
We will be upgrading our databases beginning at 11 AM ET on December 15 and this upgrade will incur downtime. This downtime is expected to be less than 2 hours.
Posted Dec 08, 2023 - 10:15 EST
This scheduled maintenance affected: API Services (Directory API, Spotlight API) and Web Applications (Bounty, Calendar App, Dashboard, kAdmis, KARS, Video Express, Pitch, Portal).